My CPS Failure - the Truth revealed.

For all technical questions. VIEWABLE without login, you need to register (free) to be able to post a question.
Post Reply
Sunfly
Full Member
Posts: 519
Joined: Fri Sep 07, 2018 9:11 am
Been thanked: 3 times

My CPS Failure - the Truth revealed.

Post by Sunfly » Sun Jul 12, 2020 8:52 am

At last I can reveal the truth about my pesky CPS fault :shock: :o :(

As you may recall, I parked the car up running beautifully, then a fortnight later it would not start or even spark. The engine light was solid on and though there were codes (15 and 17) relating to exhaust gas, nothing that should stop the engine running.
The most likely contender had to be the Dizzy and that was changed three times (thanks to cpt black - thanks Kev) but still no bloody spark - with no CPS or other codes showing its not looking good for the PCM.

Then I happened to find a blog on "engine light" codes by a chap in Canada. Unlike the Ford bible which is procedural, this was more symptomatic and what emerged from it was that there are only two faults indicated by the engine light that will result in a non starter. One is the CPS the other is the slow speed cranking sensor. NE1 everything else is passive or puts the car into limp mode.

From that I conclude that despite the fact that I have no 02 code (CPS failure) it must still be the CPS because if it were the cranking sensor NE1 (which is one of the two Hall Effect pickup's in the distributor (the other being No1 TDC), changing the dizzy for one of Kevs known good ones must have sorted it, but it didn't...

So I change the CPS (which turned out to be shorted through by the aux belt or pulley) and lo,,,! the engine runs sweetly again.

The truth! :o

But ever since, its bugged me how it could be running perfectly when I parked it, then it wont start 2 weeks later and the fault is a cut CPS wire. It simply made no sense. Then something I'd read on the Canadian guys blog came back to me and here it is.

PCM Fault Control Moding:

....................When Code 2 is present, the PCM ignores it and instead relies on NE1 for crankshaft speed data. This sensor is located in the distributor. This is not the preferred condition since the timing belt tends to make the RPM signals erratic, affecting the PCMs ability to accurately measure crankshaft speed. NOTE:1995+ GTs do not have an NE1 sensor and will not run when Code 2 is present.........................


NE1 is the cranking sensor so what I think happened was that the wire damage became terminal during the cars last journey but it carried on running on the NE1 sensor instead until the engine was switched off. The only gremlin in that theory, is that mine is a 1997 GT which he says doesn't have the NE1 sensor but we know there are regional differences with distributors as jrh's brand new American dizzy wouldn't run on a British car. I suppose it would be easy to check by looking at the Hall effect rotors.

Anyway, I'm happy to believe that when the wire failed the PCM went into survival mode and kept the engine running on info coming from the distributor until it was safe to prevent the engine from running. That sort of makes sense and maybe it might be useful info for anyone who has a similar failure in the future.

If you didn't download the Canadian guys blog at the time I'd highly recommend you do so as it is a very informative document regarding engine codes. To give an instant overview of all the faults and their effects I did an extract of his key points and posted that later in the same thread (Need some serious help please) and you might also find that helpful as a quick reference.

Post Reply

Who is online

Users browsing this forum: No registered users and 25 guests